Skip to content

FAQ

Usein kysyttyjä kysymyksiä. Selaile oikealta

Ongelma 1 - En näe Moodle -työtilaa!?

Jos et näe työtilaa https://moodle.jamk.fi, koita alapuolista itserekisteröitymistä.

Jos sekään ei auta, ole yhteydessä opettajaan.

Ongelma 2 - En näe videoita!?

  1. Sinun pitää liittyä "Data Networks" -tiimiin @student.jamk.fi -tunnuksilla. Klikkaa tästä linkistä liittyäksesi! Tiimin perusteella saat katseluoikeudet videoihin.
  2. Sinun pitää olla kirjautuneena https://o365.jamk.fi selaimessa jolla selailet materiaalia
Info: Ohjeet kuinka manuaalisesti etsitään ja liitytään tiimiin
  1. Mene Microsoft Teams -sivuille

  2. Kirjaudu sisään käyttäen @student.jamk.fi -sähköpostia

  3. Mene ja paina Teams vasemmassa palkissa

  4. Ylhäällä oikealla hakulaatikkoon kirjoita: Data Networks

  5. Klikkaa Liity

Liittymisen jälkeen on 15-30 minuutin viive katselu oikeuksien toimimiseen

  1. Älä paina request access.

  2. Odota

  3. CTRL+SHIFT+R pakottaa koko sivun päivityksen jolloin oikeudet tarkastetaan.

Ongelma 3 - Mikä on SSH?

Secure Shell (SSH) on sovellus ja protokolla, jolla yhdistät palvelimeen (tai verkkolaitteeseen) etänä hallitaksesi laitteen asetuksia (esim. avaamalla shell/komentokehote/command-line interface).

Verkonhallintaa varten SSH takaa salatun yhteyden TCP/IP -verkon lävitse.

SSH:sta on tullut de facto työkalu IT järjestelmienhallinnoijalle. Voit lukea lisää https://www.ssh.com/ssh/

Are you sure you want to continue connecting (yes/no/[fingerprint])?

SSH nojautuu kryptografisiin avaimiin salatakseen protokollan hyötykuorman (aihe kyberturvallisuudesa).

Kun otat ensimmäistä kertaa yhteyttä IPv4 osoitteeseen, SSH tykkää varoittaa sinua että luotatko todella niihin kryptografisiin avaimiin joita SSH-palvelin (verkkolaite) sinulle tarjoaa.

lubuntu@lubuntu-virtualbox:~$ ssh admin@192.168.0.253
The authenticity of host '192.168.0.253 (192.168.0.253)' can't be established.
RSA key fingerprint is SHA256:Z4hGnYYiu93ecVLqwdPo6MOImslob2XpBlwWQry4n88.
Are you sure you want to continue connecting (yes/no/[fingerprint])

Meidän harjoitusympäristö on eristetty Internet:stä eli on hyvin epätodennäköistä että olet kyberhyökkäyksen kohteena. Täten voit hyväksyä kryptografiset avaimet kirjoittamalla yes ja painamalla Enter.

@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @

Harjoitteissa voi olla tapauksia joissa vaihdat laitteen/virtuaalikoneen jolla on tietty IPv4 osoite, mutta silti yhdistät siihen jatkuvasti SSH:lla. Jokaisella laitteella on yksilöllisesti generoidut kryptografiset avainmateriaalit käytössään, joten jos niissä tapahtuu muutoksia tietylle IPv4 osoitteelle... on se hyvin epäilyttävää. Jos siis olisimme Internetissä.

Onneksemme meidän harjoitusympäristö on kohtalaisen eristetty Internet:stä, eli voimme tehdä juuri kuten varoitus meille ohjeistaa.

lubuntu@lubuntu-virtualbox:~$ ssh admin@192.168.0.253
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!    @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
SHA256:Rj8b3blWH5h7XNEYO6qT81go/FIWYUiEhOrJTlOJsBM
Please contact your system administrator.
Add correct host key in /home/lubuntu/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in /home/lubuntu/.ssh/known_hosts:6
  remove with:
  ssh-keygen -f "/home/lubuntu/.ssh/known_hosts" -R "192.168.0.253"
RSA host key for 192.168.0.253 has changed and you have requested strict checking.
Host key verification failed.
lubuntu@lubuntu-virtualbox:~$

Aja komento ssh-keygen -f "/home/lubuntu/.ssh/known_hosts" -R "192.168.0.253" poistaaksesi vanhan julkisen avaimen known_hosts tiedostosta ja ota uudelleen yhteyttä käyttämällä ssh admin@192.168.0.253 komentoa terminaalissa.

Ongelma 4 - Mitä on virtualisointi?

Virtualisoinnista yleisesti ja Lubuntu

Microsoft Stream (sharepoint) video

Virtualisointi on voimakas työkalu opetellakseen mitä tahansa IT -alasta.

"Baremetal" rauta

Normaalisti käyttöjärjestelmät pyörivät "suoraan raudalla". Tämä näkyy seuraavassa kuvassa.

Figure 1. "Baremetal"

Tärkeimpiä komponentteja ja lyhenteitä:

  • Prosessori - CPU - Central Processing Unit (Intel, AMD, ARM...)
  • Muisti - RAM - Random Access Memory (DRAM typically)
  • Kova-/Kiintolevy - HDD - Hard Disk Drive (SSD typically now)
  • Verkko-kortti - NIC - Network Interface Card (LAN, WLAN, ...)

Virtualisointi

Perusterminologia

Virtualisointi poistaa suoran raudan "sidonnaisuuden" asennetusta käyttöjärjestelmästä (Operating System - OS). Raudan ja käyttöjärjestelmän väliin tulee "virtualisointikerros". Tämän "virtualisointikerroksen" päällä ajettuja käyttöjärjestelmiä kutsutaan virtuaalikoneiksi (Virtual Machine - VM).

Figure 2. Virtualisoinnin perusteet

Tärkeimpiä komponentteja ja lyhenteitä:

  • Prosessori - vCPU - virtual Central Processing Unit
  • Muisti - vRAM - virtual Random Access Memory
  • Kova-/Kiintolevy - vHDD - virtual Hard Disk Drive
  • Verkko-kortti - vNIC - virtual Network Interface Card

Tämä "virtualisointikerros" on tyypillisesti tehty seuraavilla sovelluksilla:

  • VMware
  • VirtualBox
  • Kernel Virtual Machine - KVM

Joskus virtualisoinnista käytetään seuraavaa terminologiaa:

  • Host OS ("Isäntä käyttöjärjestelmä")
    • Suoraan raudassa pyörivä käyttöjärjestelmä (esim. Win10)
  • Guest OS ("Vierailija käyttöjärjestelmä")
    • OS of the Virtual Machine (VM)

VirtualBox

VirtualBox on avoimen lähdekoodin (Open Source Software - GPLv2 licence) virtualisointisovellus. Se on kätevä, koska vahvan komentolinjatuen (CLI -support) lisäksi siinä on hyvä graafinen käyttöliittymä (graphical user interface - GUI).

VirtualBox:n voi ladata täältä: https://www.virtualbox.org/wiki/Downloads

Virtuaalikoneet asennetaan tiettyyn kansioon isäntäkäyttöjärjestelmällä. Voit vaihtaa tätä kansiota "File -> Preferences", jossa "Default Machine Folder" voi muuttaa. LabraNet:ssä tämän pitäisi olla sinun D:\<yourstudentnumber>\ -kansio.

Sulavamman käytön vuoksi kannattaa asentaa Extension Pack. Tämän voi tehdä lataamalla Extension Pack virtualboxin sivuilta ja lisäämällä se asennukseen "File -> Preferences -> Extensions".

Ongelma 5 - AMD Ryzen -processors & switch.ova

Yhteensopivuus ongelmia AMD Ryzen -prosessoreiden ja switch.ova:n kanssa.

Onnistuminen: Tämä on ratkaistu

Kun kytkin käynnistyy, se menee epäyhteensopivuustilaan debugging, josta pääsee pois

  1. paina c ja Enter
  2. kirjoita exit ja paina Enter

Kun kytkin käynnistyy voit edetä normaalisti harjoitteiden kanssa.

Esimerkki: Ratkaisu kuvana

Kun kytkin käynnistyy, voit edetä normaalisti. Testasin virtuaalikonetta tässä tilassa ja kaikki tuntui toimivan normaalisti. Voit edetä harjoitteiden kanssa.

Ongelma 6 - En pääse kirjautumaan https://gitlab.labranet.jamk.fi

Todennäköisesti sinun JAMK tunnuksia ei ole vielä generoitu LabraNet:ssä. Voit kokeilla itsepalveluportiaalia salasanan uusimiseen: https://student.labranet.jamk.fi/password-resets/

Jos tämä ei toimi, ole yhteyksissä opettajaan.

Ongelma 7 - Virtuaalikoneet eivät käynnisty

Todennäköisesti fyysisen tietokoneesi emolevyssä ei ole virtualisoinnin tukea laitettuna päälle.

Riippuen emolevyn tyypistä... sinun pitää käynnistää tietokone BIOS/UEFI ja löytää valmistajamallista riipuen oikea välilehti, jossa virtualisoinnin voi laittaa päälle.

Esimerkkejä tästä viasta:

Bug: AMD vikailmoitus

Failed to open a session for the virtual machine Lubuntu.

Not in a hypervisor partition (HVP=0) (VERR_NEM_NOT_AVAILABLE).

AMD-V is disabled in the BIOS (or by the host OS) (VERR_SVM_DISABLED).

| Result Code:  E_FAIL (0x80004005) | Component: ConsoleWrap | Interface:IConsole {872da645-4a9b-1727-bee2-5585105b9eed} |

Intel error

"The hardware virtualization is enabled in the Acceleration section of the System page although it is not supported by the host system. It should be disabled in order to start the virtual system."

Virtualization Technology (VTx) has to be enabled in BIOS/UEFI

Ongelma 8 - Olen MAC käyttäjä ja harjoitusten repositoriotemplate ei importtaudu

Ratkaisu: MAC purkaa .zip -tiedostot automaattisesti?

Tiedoston pitää päättyä .tar.gz -tiedostopäätteeseen

Valitettavasti Safari selain (oletuksena?) purkaa .gz -päätteen tiedoston lopusta. Tämä aiheuttaa import vaiheessa ongelmia https://gitlab.labranet.jamk.fi -palvelimella.

Seuraa ohjeita korjataksesi tilanteen:

  1. Avaa Safari selain
  2. Valitse Preferences
  3. General välilehdellä ota täppä pois *Open "safe" files after downloading"

Ongelma 9 - Haluan siirtää tiedostoja isäntäkäyttöjärjestelmän ja vierailijakäyttöjärjestelmän välillä

Ratkaisu: Voit siirtää USB-tikkuja virtuaalikoneeseen seuraavan esimerkin mukaisesti

Ongelma 10 - VERR_INTNET_FLT_IF_NOT_FOUND_of_death

Bug: Joskus kytkimet eivät käynnisty antaen virheeksi - VERR_INTNET_FLT_IF_NOT_FOUND_of_death

Bug: Error message

Failed to open a session for the virtual machine Switch 1. Failed to open/create the internal network 'HostInterfaceNetworking-VirtualBox Host-Only Ethernet Adapter' (VERR_INTNET_FLT_IF_NOT_FOUND). Failed to attach the network LUN (VERR_INTNET_FLT_IF_NOT_FOUND).

Result Code: E_FAIL (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Ratkaisu

* source: Virtualbox

Ongelma 11 - Ongelmia lubuntu.ova -tiedoston kanssa

Etänä työskennellessä, usealla eri fyysisellä koneella ... on minulle raportoitu ongelmia lubuntu.ova tiedoststa

Yritän dokumentoida ongelmia vähitellen, kun niitä tulee vastaan...

Ratkaisu: Tarkasta että lubuntu.ova on latautunut eheänä

Paina WIN näppäintä ja kirjoita Powershell. Käynnistä kyseinen sovellus.

Kirjoita kyseisen esimerkin komento oikeassa kansiossa

PS D:\sahka> Get-FileHash lubuntu.ova | Format-List

Algorithm : SHA256
Hash      : CE68B82FB8439372A7776D6ED7F253F854C26EE0E44B880C4D51207AAA94070F
Path      : D:\sahka\lubuntu.ova

PS D:\sahka>
Esimerkki: kuvankaappauksena

Ongelma 12 - Kuinka tallennan konfiguraation verkkolaitteesta?

Verkkolaitteiden konsolit virtuaalikoneissa eivät tue hiiren käyttöä, eli maalaaminen/kopioiminen niistä ei onnistu. Tässä on video kuinka tehdä SSH -yhteys lubuntu.ova:sta ja kopioida konfiguraatio sen kautta.

Esimerkki: Video tallennusprosessista

Microsoft Stream (on sharepoint) video

Ongelma 13 - Kuinka verkkoadapterit toimivat VirtualBox:ssa?

Lubuntu

Lubuntu toimii meidän työpöytätietokoneena (workstation) verkossa. Sillä on vain yksi adapteri (Network Adapter). Tämä kuvastaa päivittäistä työskentelyämme päätelaitteila, jotka ovat yleensä aktiivisia vain yhdessä tietoverkossa.

Tässä on visualisaatio kuvana

  1. Kuinka virtualisointi näkee verkkokortin (Network Interface Card - NIC)
  2. Kuinka käyttöjärjestelmä näkee verkkokortin (Network Interface Card - NIC)
  3. Kuinka se piirretään/visualisoidaan topologiaan

Kytkin

Kytkin on OSI -mallin tason 2 verkkolaite harjoitteissa. Sillä on useampia rajapintoja. Kyseiset rajapinnat kytketään yleensä eri päätelaitteisiin.

Tässä on visualisaatio kuvana

  1. Kuinka virtualisointi näkee verkkokortin (Network Interface Card - NIC)
  2. Kuinka käyttöjärjestelmä näkee verkkokortin (Network Interface Card - NIC)
  3. Kuinka se piirretään/visualisoidaan topologiaan

Varoitus: Ensimmäinen adapteri switch.ova virtuaali koneessa on aina varattu hallintaportille (MGMT)

Tätä porttia kutsutaan out-of-band hallintaportiksi, josta lisää TCP, UDP ja verkon konfiguraation hallinta (SSH, HTTP) - viikolla 10.

Vyos

Reititin on OSI -mallin tason 3 verkkolaite harjoitteissa. Sillä on useampia rajapintoja. Kyseiset rajapinnat kytketään yleensä eri verkkoihin.

Tässä on visualisaatio kuvana

  1. Kuinka virtualisointi näkee verkkokortin (Network Interface Card - NIC)
  2. Kuinka käyttöjärjestelmä näkee verkkokortin (Network Interface Card - NIC)
  3. Kuinka se piirretään/visualisoidaan topologiaan

Ongelma 14 - Kirjoitin vääriä asetuksia! Kuinka voin poistaa/muuttaa asetukset?

Komentoja konfiguraation poistamiseen/muuttamiseen. Komennot materiaalissa ilmaantumisen järjestyksessä.

Enabloi/disabloi port

enable port <#>

disable port <#>

Luo / Poista VLAN

create vlan <name>

delete vlan <name>

Muuta VLAN name/tag

configure vlan <name> tag <new_tag>

configure vlan <name> name <new_name>

Lisää/poista VLAN portista tagged/untagged

configure vlan <name> add ports <#> <untagged/tagged>

configure vlan <name> delete ports <#> <untagged/tagged>

Konfiguroi/poista VLAN IP osoite kytkimestä

configure vlan <name> ipaddress <x.x.x.x/xx>

unconfigure vlan <name> ipaddress

aseta/poista IP osoite reitittimen (Vyos) rajapinnasta

set interfaces ethernet ethX vif <tag> address <x.x.x.x/xx>

delete interfaces ethernet ethX vif <tag> address <x.x.x.x/xx>

Konfiguroi/poista oletusyhdyskäytävä kytkimestä

configure iproute add default <ip of router vif interface in network devices vlan>

configure iproute delete default

Enabloi/disabloi SSH kytkimellä (EXOS)

enable ssh2 port 22

disable ssh2

Enabloi/disabloi SSH reittimellä (Vyos)

set service ssh port <number>

delete service ssh port <number>

Aseta DHCP konfiguraatio tai poista se

set service dhcp-server shared-network-name VLAN5 subnet 192.168.0.0/24 default-router 192.168.0.254
set service dhcp-server shared-network-name VLAN5 subnet 192.168.0.0/24 range PCs start 192.168.0.2
set service dhcp-server shared-network-name VLAN5 subnet 192.168.0.0/24 range PCs stop 192.168.0.250

delete service dhcp-server <add parameters if you want to specify what to delete>

e.g. delete service dhcp-server shared-network-name VLAN5 poistaa koko DHCP konfiguraation annetusta shared-network-name:sta

Asettaa/poistaa staattisen reitin reitittimellä (Vyos)

set protocols static route <subnet> next-hop <how to get there / next-hop>

delete protocols static route <subnet>

Lisää/poistaa VLANeja Spanning Tree:stä

configure stpd s0 add vlan <name> ports all

configure stpd s0 delete vlan <name> ports all

Konfiguroi/poistaa Spanning Tree kytkimen prioriteetin

configure stpd s0 priority <value>

unconfigure stpd s0 priority <value>

Enabloi/disabloi Spanning Tree kytkimestä

enable stpd s0

disable stpd s0

Asettaa/poistaa OSPF router-id:n reitittimestä (Vyos)

set protocols ospf parameters router-id <x.x.x.x>

delete protocols ospf parameters router-id

Asettaa/poistaa loopback -rajapinnan

set interfaces loopback lo address <x.x.x.x/32>

delete interfaces loopback lo address

Asettaa/poistaa aliverkon OSPF alueesta (Enabloi/disabloi OSPF Hello -viestit & aliverkon mainostus)

set protocols ospf area 0 network <x.x.x.x/xx>

delete protocols ospf area 0 network <x.x.x.x/xx>

Asettaa/poistaa palomuurin konfiguraation

set zone-policy zone <name> default-action drop

delete zone-policy zone <name>

set firewall name LAN_to_WAN default-action drop
set firewall name LAN_to_WAN enable-default-log
set firewall name LAN_to_WAN rule 10 action accept
set firewall name LAN_to_WAN rule 10 destination port 80
set firewall name LAN_to_WAN rule 10 protocol tcp
set firewall name LAN_to_WAN rule 10 log enable
set firewall name LAN_to_WAN rule 11 action accept
set firewall name LAN_to_WAN rule 11 destination port 443
set firewall name LAN_to_WAN rule 11 protocol tcp
set firewall name LAN_to_WAN rule 11 log enable
set firewall name LAN_to_WAN rule 20 action accept
set firewall name LAN_to_WAN rule 20 protocol icmp
set firewall name LAN_to_WAN rule 20 log enable
set firewall name LAN_to_WAN rule 30 action accept
set firewall name LAN_to_WAN rule 30 destination port 22
set firewall name LAN_to_WAN rule 30 protocol tcp
set firewall name LAN_to_WAN rule 30 log enable
set firewall name LAN_to_WAN rule 40 action accept
set firewall name LAN_to_WAN rule 40 destination port 53
set firewall name LAN_to_WAN rule 40 protocol udp
set firewall name LAN_to_WAN rule 40 log enable

delete firewall name LAN_to_WAN - poistaa koko sääntötaulun LAN_to_WAN

delete firewall name LAN_to_WAN default-action drop Poistaa sääntötaulun LAN_to_WAN yksittäisen asetuksen

delete firewall name LAN_to_WAN rule 10 - poistaa koko säännön 10 sääntötaulusta LAN_to_WAN

delete firewall name LAN_to_WAN rule 10 destination port 80 - poistaa yksittäisen asetuksen säännöstä 10 sääntötaulussa LAN_to_WAN

Asettaa/poistaa NAT konfiguraation

set nat source rule 10 outbound-interface eth0
set nat source rule 10 translation address masquerade
set nat source rule 10 source address 10.0.0.0/16

delete nat source rule 10 - poistaa koko säännön

delete nat source rule 10 outbound-interface eth0 - poistaa yksittäisen määritteen säännöstä 10

set nat destination rule 10 destination address 132.35.66.10
set nat destination rule 10 inbound-interface eth0
set nat destination rule 10 translation address 10.0.10.8

delete nat source rule 10 - poistaa koko säännön

delete nat source rule 10 inbound-interface eth0 - poistaa yksittäisen määritteen säännöstä 10

Enabloi/disabloi HTTP:n kytkimellä (EXOS)

enable web http

disable web http

Enabloi/disabloi HTTPS:n reitittimellä (Vyos)

set service https listen-address <IPv4 address on the Router - e.g. loopback>

delete service https

Konfiguroi/poistaa IPv6 konfiguraation reitittimellä (Vyos)

set interfaces ethernet eth0 vif 5 address 2001:dead:beef:5::1/64

delete interfaces ethernet eth0 vif 5 address 2001:dead:beef:5::1/64

set protocols ospfv3 parameters router-id <x.x.x.x>

delete protocols ospfv3 parameters router-id <x.x.x.x>

set protocols ospfv3 area 0.0.0.0 interface <interface>

delete protocols ospfv3 area 0.0.0.0 interface <interface>

Konfiguroi/poistaa BGP konfiguraation reitittimellä (Vyos)

set protocols bgp 111 neighbor 2.2.2.2 remote-as 222

delete protocols bgp 111 neighbor 2.2.2.2

set protocols bgp 111 network 1.1.1.0/24

delete protocols bgp 111 network 1.1.1.0/24

set protocols bgp 111 redistribute ospf

delete protocols bgp 111 redistribute ospf

set protocols ospf redistribute bgp metric-type 2

delete protocols ospf redistribute bgp metric-type 2

Ongelma 15 - Mitä wireshark tekee "visuaalisesti"/"graafisesti piirrettynä"?

Wireshark Lubuntu kiinnittää itsensä kuuntelemaan "kaapelia" (internal network/<kaapeli>) ja haistelee/nauhoittaa/salakuuntelee liikennettä joka kaapelissa kulkee.

Ongelma 16 - Kuinka voin siirtää virtuaalikoneita fyysiseltä koneelta toiselle?

Valitse virtuaalikone(et) jotka haluat siirtää ja valitse File -> Export Appliance....

Voit lisätä lisää virtuaalikoneita siirrettäväksi, jos toivot niin, mutta etukäteen valitut ovat korostettuna.

Valitse kansio johon siirrossa olevien koneiden tiedosto (.ova) tallennetaan (step 1). Muista valita Include all network adapter MAC addresses (step 2).

Seuraavassa ikkunassa sinun ei tarvitse lisätä enää tietoja. Paina suoraan Export.

Esimerkissä Appliance.ova muodostuu kansioon... Aikaa kestää sen verran kuin valitset virtuaalikoneita (asennusten koko vaikuttaa tiedoston kokoon ja sen levylle kirjoittamisen kestoon).

Voit nyt siirtää Appliance.ova tiedoston sopivalle siirtomedialle (e.g. USB -tikku/-kovalevy), josta kopioit sitten Appliance.ova -tiedoston uudelle fyysiselle tietokoneelle.

Tärkeää: Kun tuot Appliance.ova sisään uudelle fyysiselle koneelle (import), muista valita taas Include all network adapter MAC addresses

Ongelma 17 - Vyos virtuaalikone kadottaa asetuksensa!?

Muista aina sammuttaa Vyos kauniisti poweroff -komennolla.

Jos Vyos on tyhjänä konfiguraatiosta, voit ladata konfiguraation Lubuntulta olettaen että reitittimellä ja lubuntulla on IP -yhteys toisiinsa (ping) -> konfiguraation lataamiseen reitittimellä annetaan käsky load http://<lubuntu-vm-ip>/<configuration-file>

Tätä varten konfiguraatio tiedoston pitää olla /var/www/html/ -kansiossa Lubuntu virtuaalikoneella.

Ongelma 18 - DMA interrupt recovery

Tämä vika on havaittu vanhemmilla (Intel i5) prosessoreilla.

DMA interrupt viesti kytkimen käynnistyessä

DMA interrupt ratkaisu

Ongelma 19 - Exam sanoo Rejected vaikka päälle 50% oikein!?

Kysymys: Moi, kävin EXAM-kokeessa tekemässä tietoverkkojen kokeen ja sain pisteitä siitä 15/30 ja näyttää etten olisi päässyt sitä lävitse. Eikös 50% riittänyt hyväksyttyyn arvosanaan?

Vastaus: Jos olet palauttanut hyväksyttäviä tehtäviä vähintään 5 Moodlessa ja saanut hyväksytyn arvioinnin, siirtyy tapauksesi numeraalisen arvioinnin kohteeksi. Tällöin läpäisyrajasi kokeesta on 15/30 pistettä (eli 50% oikein). Exam -järjestelmä tuntee vain yhden läpäisyrajan ja siihen on asetettu 70% => 21/30 rajaksi (HYV/HYL tapauksiin, joissa tehtäviä ei ole palautettu). Examin koepisteet käydään lävitse lopullista arviointia annettaessa jolloin tarkastellaan Moodlen palautukset ja Exam pisteet. Ei tarvitse huolestua vaikka Exam sanoisi "Rejected".

Ongelma 20 - Windows 11 Muistin Suojaaminen pois päältä

Virtualisointi varaa käyttöjärjestelmän kautta muistia. Windows 11 käyttöjärjestelmässä voi olla tarpeellista poistaa käytöstä Muistin suojaus. Sen voi palauttaa harjoitteiden jälkeen takaisin päälle halutessaan.

Laitteen suojaaminen windowsin suojauksen avulla

Voit käyttää alla kuvattuja ominaisuuksia napauttamalla Windowsin Aloituspainiketta, kirjoittamalla Windowsin suojaus, valitsemalla sen tuloksista ja valitsemalla sitten Laitteen suojaus.

Muistin eheys

Muistin eheys on ytimen eristyksen ominaisuus. Ottamalla Muistin eheys -toiminnon käyttöön voit estää haitallista koodia pääsemästä hyökkäyksen tapauksessa erittäin turvallisiin prosesseihin.

Ongelma 21 - Haluan tehdä harjoituksia luokassa kontaktituntien ulkopuolella. Miten näen tilojenvaraukset?

Laboratory Network classrooms are quite available.

Tapa 1: https://opiskelija.peppi.jamk.fi - vaatii kirjautumisen

  • Mene selaimella https://opiskelija.peppi.jamk.fi
  • Kirjaudu
  • Paina: Kalenteri
  • Mene Tilojenvaraus
  • Poista henkilöistä oma nimesi painamalla x sen vierestä
  • Lisää tila (esim. D331)
  • Selaa oikealle viikolle

Tapa 2: https://lukkarit.peppi.jamk.fi - ei vaadi kirjautumista

  • Mene selaimella https://lukkarit.peppi.jamk.fi
  • Hae tiloja
  • Lisää kenttään luokka jonka haluat (esim. P2_D331) ja paina Hae
  • Paina + Lisää
  • Paina Piilota hakutulokset
  • Selaa viikkojen lävitse nähdäksesi tilankäyttö viikoilla
  • Lutakon kampus on auki Dynamon pääovi, ma–pe klo 7.30–18.00

Ongelma 22 - Haluan henkilökohtaista Teams ohjausta 1:1 -chatissä

Valitettavasti tämä malli ei skaalaudu opettajan puolelta. Opintojaksolla on ~400-600 opiskelijaa vuosittain. Siihen jos kertaa virheiden määrät & chat viestit x opintojaksojen määrä (x opiskelijoiden määrä)... on edessä opettajien burnout.

Toimintamalli:

  1. Tarkasta Data Networks -teams kanavalta virheesi teksti (Teams:ssa on hakutoiminto!!!), koska todennäköisesti et ole uniikki yksisarvinen ongelmasi kanssa
  2. Kysy ryhmäsi keskustelukanavista, jos yleinen Data Networks -teams jännittää. Insinööritieteiden osana on myös kehittää osaamista Communication & Team-working vaikka labrat tehdään yksilöinä.
  3. Jos selkeää vastausta ei löydy, aloita keskustelulanka Data Networks -teams:ssa viasta
    • Joku opintojakson opettaja vastaa kunhan kerkeää
  4. Nauti ratkaisusta ja ettei tieto vikatilanteista siiloudu 1:1 chat keskustelujen uumeniin

Programme outcomes - EUR-ACE

(e) The Programme Outcomes are described here separately for both Bachelor and Master Degree programmes with reference to the following eight learning areas:

Knowledge and understanding;

Engineering Analysis;

Engineering Design;

Investigations;

Engineering Practice;

Making Judgements;

Communication and Team-working;

Lifelong Learning.

Ongelma N